Railroad Line Forums
Railroad Line Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Model Railroad Forums
 Mid Scale Model Railroad Forum
 Painting Zamak
 New Topic  Reply to Topic
Author Previous Topic Topic Next Topic  

veets
New Hire

USA
5 Posts

Posted - 12/06/2019 :  3:48:30 PM  Show Profile  Reply with Quote
Greetings from a long-time lurker.

I came into procession of a number of Bowser Brill trolleys, all unpainted, in their original boxes. This was cool, because I had one when I was kid that I failed to complete, and which is long lost but fondly remembered.

The problem? I cleaned the shell of one and attempted priming it, first with Rust-Oleum etching primer, later with Badger's Stynylrez primer. Both failed to adhere to one part of the roof.

I'v stripped it down again with a good soaking in thinner, which removed the paint, but left the primer in the places it adhered to. Which is everywhere but that one part of the roof.

My next thought was a vinegar soak before another application of the Rust-Oleum. But before I do that, I wonder if any of you has any wisdom to share?

I'd post a photo, but I don't see the "insert a file" icon on my screen and the imaging posting button wants a URL.

(Moderator, please feel free to move this post, if I've wandered into the wrong sub-forum.)

BurleyJim
Fireman

USA
4834 Posts

Posted - 12/06/2019 :  4:17:45 PM  Show Profile  Reply with Quote
Hi Veets,

You might try rubbing the un-primered surface with some #600 grit wet/dry sandpaper to give that primer a little 'tooth' to adhere too. Go easy. you just want to break any glaze on the surface.

Jim
Go to Top of Page

SAFN SAAP
Engine Wiper

USA
431 Posts

Posted - 12/06/2019 :  4:24:08 PM  Show Profile  Reply with Quote
Hey Veets,

Here is what I have done:

Get a brass brush from Lowes, Home Depot, or your hardware store. Work the casting with a file or a dremel bit to clear all the parting lines and flash. Once done, then take the brass brush and scrub it until the metal shines. Then give it a good vinegar bath undiluted, and then rinse with warm water. Then hit with the brass brush again. After everything is dry, prime with an oxide color. Some bake in the oven at a real low temp (125*) for 20 minutes. Then paint. You should have no adhesion problems.

Levi
Go to Top of Page

deemery
Fireman

USA
7967 Posts

Posted - 12/06/2019 :  4:26:26 PM  Show Profile  Reply with Quote
"prime with an oxide color" - using a solvent based paint, not an acrylic!

dave

Modeling 1890s (because the voices in my head told me to)
Go to Top of Page

veets
New Hire

USA
5 Posts

Posted - 12/06/2019 :  6:04:00 PM  Show Profile  Reply with Quote
So now I have a plan of attack. Thank you all for your advice. I'll let you know what I try and how I make out.

(I'm sure this has been asked a million times, but would anyone care to offer a link to a method for posting jpg from Chrome. I'm not a complete noob -- I've been on the Internet since before there was a www -- but I can't seem to get this. I did look at all of the FAQs, too. Thanks again!)
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
Jump To:
Railroad Line Forums © 2000-19 Railroad Line Co. Go To Top Of Page
Steam was generated in 0.17 seconds. Snitz Forums 2000